Back to overview
Downtime

HTTP API unreachable (Railway edge network outage)

May 19, 2026 at 10:41pm UTC
Affected services
Ligate HTTP API
Ligate explorer
ligate.io
themisra.xyz

Resolved
May 24, 2026 at 9:06pm UTC

Explorer indexer is fully caught up. indexer_height and head_height are both at 134000, lag is 0. The explorer is now reflecting current chain state. Marking resolved. This closes out the Railway outage incident opened 2026-05-19 22:41 UTC.

Updated
May 20, 2026 at 10:15am UTC

Explorer indexer is fully caught up. indexer_height is 69936 against head_height 69937 (1-slot real-time lag). Block, transaction, and attestation data on explorer.ligate.io are current. Closing the explorer card out. Incident resolved end to end.

Updated
May 20, 2026 at 1:39am UTC

api.ligate.io is reachable again. The outage lasted 2 hours 57 minutes (original incident opened 2026-05-19 22:41 UTC). Railway restored access to their edge network and our API service is responding.

The indexer task inside the API service has not yet caught up after the restart. indexer_height is currently null while head_height is at 64777. The explorer page itself is reachable, but recent block and transaction data will be empty or stale until the indexer reconnects to Postgres and works through the backlog. Marking the explorer as degraded. A follow-up update will confirm when the indexer is back at zero lag.

Updated
May 20, 2026 at 1:18am UTC

api.ligate.io is still unreachable, roughly 2 hours 37 minutes into the outage. No change on our end.

Latest from Railway, dated 2026-05-20 00:37 UTC: their incident remains at "identified" status. Per their status page, partial Google Cloud access has been restored and they are working directly with Google support to bring back the dashboard, API, and control plane. No ETA was provided by Railway.

Next update from us within 60 minutes, or sooner if api.ligate.io recovers.

Updated
May 20, 2026 at 12:13am UTC

api.ligate.io is still unreachable, roughly 65 minutes into the outage. No change on our end.

Upstream update from Railway: their incident has moved from "investigating" to "identified." Per their status page, the root cause is that Google Cloud blocked Railway's account, taking down portions of Railway's edge network. Railway has escalated with Google and reports partial access restoration is underway. Our API service depends on Railway's edge, so it will return when Railway's GCP access is fully restored.

Next update from us within 60 minutes, or sooner if api.ligate.io recovers.

Updated
May 19, 2026 at 10:47pm UTC

Flipping the explorer to degraded. explorer.ligate.io itself is reachable (the Next.js page renders on Vercel), but it sources block, transaction, and account data from api.ligate.io, which is down with the Railway outage. The page loads, but data panels will be empty or stale until Railway recovers.

API remains down. Same incident, no new upstream signal from Railway yet.

Created
May 19, 2026 at 10:41pm UTC

api.ligate.io is currently unreachable. Requests time out before reaching our service.

Upstream cause: Railway, which hosts the API service, is reporting a major edge network outage on its public status page (status.railway.com). Their incident is marked "investigating" and lists "no healthy upstream" and "unconditional drop overload" errors across affected projects. Railway's own dashboard and management API are also impaired, so we cannot redeploy or fail over while their edge is down.

Unaffected: chain RPC (rpc.ligate.io), explorer (explorer.ligate.io), and the websites (ligate.io, themisra.xyz). The chain itself is producing blocks normally.

Next update from us within 60 minutes, or sooner if Railway moves their incident to "identified" or "monitoring."